Europe/Berlin

ISO8601: 2026-07-04T15:29:15+02:00

DIN 5008: 15:29:15 Uhr, 04.07.2026

Unix Epoch: 1783171755

Get In Touch

Subscribe to updates

Public API

Explore the public API documentation in Swagger UI.

Open API Docs

All systems are operational.

13.06.2026

See Affected Components

Component Group Name Status
Region DBL Block Storage Operational
2 weeks ago —
Fixed

Fixed

2 weeks ago —

This issue has been fixed.

Fixed

2 weeks ago —

Update :

The blockstorage performance issues were limited between 20:30 - 20:46 (CET) The issues were investigated and fixed during this timeframe.

We are sorry for the inconvenience

Investigating

2 weeks ago —

Currently investigating.

2 weeks ago —

Affected Components: SysEleven Stack, region DBL

Description: A change in configuration caused an unexpected network outage for the region for ~2 minutes

Customer Impact: Connectivity is restricted

Incident UUID c7e6d335-d653-4115-86f7-2927e270c2a3