At the moment we are facing connectivitiy issues in region DBL.
We will keep you informed and apologise for any inconveniences.
Update : We are still continuing the investigation, there has been an improvement of the situation but there is still network degradation
Update : We have identified the issue and took measures